Summary:ASTERISK-22148: res/stasis: rename translation units; consider a rename of Stasis App to something else
Reporter:Matt Jordan (mjordan)Labels:Asterisk12
Date Opened:2013-07-20 17:23:57Date Closed:2013-08-02 09:27:59
Versions:12 Frequency of
Description:I keep on thinking of this:

One name => one purpose.

Right now, "Stasis" still feels like it could be confusing. When I think of Stasis, I think of the core message bus and Stasis messages that move across the message bus. I also think of the Stasis message cache. These concepts all feel tied together.

The concept of a Stasis application and a channel being "put in Stasis" doesn't feel like it is the same. Theoretically, we could completely nuke the Stasis message bus and replace it with another message bus, and the channels would still be in a holding pattern with something else controlling and driving them.

That makes me think we have two distinct pieces of functionality with the same name, which I'm not a fan of.

I understand that Stasis as an application is not ARI - the interface to control the channels is *not* the plumbing that holds the channels and interprets the control. But neither is that the core message bus.

This needs a different name.

In addition, several of the translation units that make up "res/stasis" conflict with existing items or are named too generically, i.e., we already have an "app.h" in Asterisk, "command" could be anything, etc.

Whatever we name it, I'd prefer these units to be {{name_app}}, etc.
Comments:By: Matt Jordan (mjordan) 2013-08-02 09:27:59.631-0500

Suspending. The names are good enough for the first test release; if we need to name it to something else we will.