|Summary:||ASTERISK-21925: Clean up the parking API in res_parking|
|Reporter:||Matt Jordan (mjordan)||Labels:||Asterisk12|
|Date Opened:||2013-06-19 19:51:36||Date Closed:||2013-08-02 09:27:11|
|Description:||Perform a sweep of the API defined in res_parking for:
* naming conventions.
** Functions that are protected within the set of parking files should be prefixed with a common name, i.e., parking_
** Structs that are protected within the set of parking files should be prefixed with a common name
* Rename parking_ui - we don't typically use the nomenclature 'ui' for CLI commands.
* Implement module unloading/reloading properly
* Determine if all CEL Park events are being relayed properly. If so, remove the TODO in parking_bridge
* Determine if we need a parking swap message.
Finally, we need to also:
* Remove all legacy parking code from features.c that is no longer used
* Any channel drivers still referencing legacy code in features.c needs to be determined if the public transfer bridge functions will work for their intended use cases.
|Comments:||By: Matt Jordan (mjordan) 2013-08-02 09:27:04.250-0500|
I think we've taken this about as far as we can for now. While additional cleanup would be good, at this point it makes more sense to focus on the functional failures. Suspending.