[Home]

Summary:ASTERISK-16951: [patch] configure.ac in 1.4.37 broken with autoconf 2.60
Reporter:St├ęphan Kochen (skochen)Labels:patch
Date Opened:2010-11-12 07:52:42.000-0600Date Closed:2011-12-01 11:22:18.000-0600
Priority:MinorRegression?Yes
Status:Closed/CompleteComponents:Core/BuildSystem
Versions:13.19.0 15.2.0 Frequency of
Occurrence
Related
Issues:
Environment:Attachments:( 0) compute_int.patch
Description:It looks like with revision 290177, because of AC_COMPUTE_INT, the autoconf requirement was silently bumped to at least 2.60a. But AC_PREREQ doesn't reflect this.

Generating a configure script with 2.60 produces syntax errors such as:

./configure: line 20765: syntax error near unexpected token `ac_cv_sizeof_fd_set_fds_bits,'
./configure: line 20765: `AC_COMPUTE_INT(ac_cv_sizeof_fd_set_fds_bits, sizeof(foo.fds_bits[[0]]), $ac_includes_default'
error: Bad exit status from /var/tmp/rpm-tmp.1037 (%build)

(The macro simply isn't expanded, because it doesn't exist.)

****** ADDITIONAL INFORMATION ******

I've tested and successfully built with autoconf 2.60b, but mind that both 2.60a and 2.60b are old and officially unstable releases.
Comments:By: Paul Belanger (pabelanger) 2011-12-01 11:22:00.748-0600

Per the Asterisk maintenance timeline page at http://www.asterisk.org/asterisk-versions maintenance (bug) support for the 1.4 and 1.6.x branches has ended. For continued maintenance support please move to the 1.8 branch which is a long term support (LTS) branch. For more information about branch support, please see https://wiki.asterisk.org/wiki/display/AST/Asterisk+Versions.  After testing with Asterisk 1.8, if you find this problem has not been resolved, please open a new issue against Asterisk 1.8.



By: Friendly Automation (friendly-automation) 2018-02-01 10:27:20.784-0600

Change 7966 merged by Jenkins2:
BuildSystem: Raise autoconf version requirement to 2.60a.

[https://gerrit.asterisk.org/7966|https://gerrit.asterisk.org/7966]

By: Friendly Automation (friendly-automation) 2018-02-01 10:31:41.006-0600

Change 7965 merged by Jenkins2:
BuildSystem: Raise autoconf version requirement to 2.60a.

[https://gerrit.asterisk.org/7965|https://gerrit.asterisk.org/7965]

By: Friendly Automation (friendly-automation) 2018-02-01 10:42:22.926-0600

Change 7967 merged by George Joseph:
BuildSystem: Raise autoconf version requirement to 2.60a.

[https://gerrit.asterisk.org/7967|https://gerrit.asterisk.org/7967]