|Summary:||ASTERISK-05304: [patch] [post-1.2] QUEUE_MEMBER_LIST|
|Reporter:||Tilghman Lesher (tilghman)||Labels:|
|Date Opened:||2005-10-17 15:59:10||Date Closed:||2006-01-13 16:00:04.000-0600|
|Environment:||Attachments:||( 0) 20051228__queuememberlist.diff.txt|
|Description:||Currently, you can add, remove agents from the dialplan, CLI, manager, but you can only see the list of current agents from the CLI and manager. This shortcoming is addressed with this patch.|
|Comments:||By: Tilghman Lesher (tilghman) 2005-12-01 14:27:53.000-0600|
Updated patch to current.
By: Olle Johansson (oej) 2005-12-14 10:51:44.000-0600
I realize that we have to be careful with naming here. The current dial plan function uses the wrong terminology.
This what we have been using so far:
- A queue has "members"
- members consist of either a device (tech/name) or an agent
- agents are devices logged in through the agent channel
- thus, not all queue members are agents.
Any function that lists who's part of a queue has to be "queuemembers", not "queueagents" which is misleading. The current dialplan function needs to change to not continue to confuse people about this.
What do you think, Corydon76?
By: Tilghman Lesher (tilghman) 2005-12-14 11:11:57.000-0600
But on the other hand, the common name for persons answering a queue is "Agent" -- whether or not they're actually logged in as an agent or logged in via a device. The real confusion that we have to avoid is to differentiate between those ANSWERING the queue (agents) and those WAITING in the queue (what do we call them?). Although "member" is clear to those of us who know the source, it is ambiguous to most people.
I'm not committed to QUEUEAGENTLIST, but it's certainly more clear than QUEUEMEMBERLIST.
By: Olle Johansson (oej) 2005-12-30 01:11:45.000-0600
We need to be strict in naming. If we start using "agent" as the name as someone that is a member of the group that answers, we need to rename the entity that logs in to the agent channel, as well as the channel.
I agree that most people find it confusing that the answering entity is not always called an "agent". I just want clear definitions that we can communicate in training and documentation. If we start mixing it without a clear definition, it will be very messy.
By: Matt O'Gorman (mogorman) 2006-01-13 15:59:47.000-0600
Committed revision 8069. into trunk