Summary:ASTERISK-03335: [patch] Advancec configuration file for meetme
Reporter:mochouinard (mochouinard)Labels:
Date Opened:2005-01-23 11:05:01.000-0600Date Closed:2011-06-07 14:04:50
Versions:Frequency of
Environment:Attachments:( 0) app_meetme.c_advconfig_rev1.txt
( 1) meetme.conf.example.txt
Description:This patch is to make meetme.conf more usefull, and allow to add more feature in the feture.  You can call Meetme using MeetMeAdv(conferencenumber).  It support multiple PIN support with different option depending of the pin.

see meetme.conf.example.txt attached for example config file


REV1 is a functional prototype, Idlike input on this before I/we continue. Thanks
Comments:By: mochouinard (mochouinard) 2005-01-23 11:10:08.000-0600

Ok note, current patch is based to NEED A PIN...  There is so much options we can do when we call a conference now, I wanted to provide 1 atless.  So you need to use PIN for the moment

By: Mark Spencer (markster) 2005-01-23 12:48:02.000-0600

Neat idea, but why does it need to be called separately with a new application?

Also, if we're going to start a new meetme, perhaps you and anthm can combine your feature goals together?

By: mochouinard (mochouinard) 2005-01-23 15:00:01.000-0600

I wanted to stay away of the way we currently create/handle joining a conference.   There is already some problem with the cleanup of conference that I think sometime doesn't occurs, and it should. I personally think the old way to call MeetMe should be removed, in replacement with something like this patch.  But I know about backward compability so... I was thinking to modify how meetme is called together, to be base on this patch instead.  But I havent figured how to do everything yet.  For the moment, I'll stop posting new feature, because it will be hell to update them all, also, I wish this patch, or a derivative of this patch get in so new feature can be added.  I'll try to reach anthm and see if he want to work on this.

By: Mark Spencer (markster) 2005-01-23 15:06:47.000-0600

I don't see how this is incompatible with the way meetme is called today.  You can simply use this to change the default options you want on and allow the command line routines to continue to add additional ones right?

By: mochouinard (mochouinard) 2005-01-23 15:26:11.000-0600

What I mean is, I dont like how conf_exec do stuff.  I would ratter make the new meetmeadv support current meetme options, than modifying conf_exec.  I tryed to make Meetmeadv as clean as posible, with the less ammount of code as posible.  So reading it is easier.  It why I made this masterbuild_conf, I don't think adding those variables were supose to be in there. But I didnt want to change the rest of the code.  It would be a good thing to get rid of the conf_exec and everything refering to it, and building in cleaner way.  Maybe a app_conf should be a good thing. I don't know.  The way conf_run work, aint THAT bad in my view, and stuff we dont like could cleanup easily.  The part that I think was more of a headake is the conf_exec, also the meetme.conf was very dummy config file, it could have being discarded completly, and just set the PIN within the call for MeetMe if needed.  Anyway hope I make little sence here

By: Kevin P. Fleming (kpfleming) 2005-01-23 17:15:21.000-0600

Personally I think the "admin=yes/pin=XXXX" combo is very fragile... it's not obvious that the lines relate to each other. It would almost be better to define something like a "user" with admin rights and a PIN code, and then "allow" that user in the conference... but that's a pretty big change.

By: mochouinard (mochouinard) 2005-01-23 17:51:32.000-0600

Maybe we can reset the admin=yes flag at each pin.  But I dont know, I guess it better to educate to put lower security access first, and at the end the higher security access.  Also it already how it work in other configs file, like zapata.conf

edited on: 01-23-05 17:58

By: Brian West (bkw918) 2005-01-23 20:14:52.000-0600

Actually I spoke with Mark and he has given the go ahead to start MeetMe2 ( or the like)  but it needs to be backwards compatible.  Moc, anthm, myself and anyone else that wants to be involved to hash out the features and methods.


By: Olle Johansson (oej) 2005-01-27 00:59:13.000-0600

Mouchinard: If you want it to work like in zapata.conf, then you need to have the "pin => code" syntax to create an object. Like:


By: Kevin P. Fleming (kpfleming) 2005-01-27 08:41:52.000-0600

That's true, but in reality the configuration parser treats "var=value" and "var=>value" indentically. It's only a syntactic crutch for the users to _see_ that the values relate to each other; if they accidentally use plain "=" for all of their entries it will work the same way.

By: mochouinard (mochouinard) 2005-02-27 20:01:45.000-0600

Exactly, I really think it just a matter of educating user about the order of things, like zapata.conf

By: Kevin P. Fleming (kpfleming) 2005-02-27 23:57:34.000-0600

Well, as it turns out, when I made that statement I was in error :-)

Using '=>' does have one side effect: it sets the 'object' flag in the config variable structure created by that line. While nearly all config-file-using modules don't care, chan_zap does, and there may be others.

Just wanted to set the record straight.

By: Mark Spencer (markster) 2005-02-28 00:14:26.000-0600

chan_zap does not actually care if it's = or =>, it's the keyword that is important.  The = vs. => is merely syntactic sugar to make it easier to read config files.  The only reason it's stored at all was back when I was trying to make ast_config's able to be read and then written back (with comment preservation, etc).

By: Kevin P. Fleming (kpfleming) 2005-02-28 00:20:25.000-0600

Ahh, my mistake... thanks for the clarification.

By: mochouinard (mochouinard) 2005-03-16 20:56:11.000-0600

After discutions, it seem this wont be accepted into cvs.

By: mochouinard (mochouinard) 2005-04-02 11:54:44.000-0600

really wish to get this patch (updated ofcourse) into CVS, and in conjunction with patch ASTERISK-3842

By: Michael Jerris (mikej) 2005-05-23 22:01:34

Can we suspend this and roll it into the work done on meetme re-design in ASTERISK-4169.  I lean towards testing\committing the redesign as a new meetme, then, as all the current meetme functionality is ported to it, renaming it to meetme.  And implementing all new features only in the new version.

By: Clod Patry (junky) 2005-06-13 18:42:08

Apparently, that patch won't go in CVS. Like bkw already suggested it, let's start MeetMe2 instead of patches on patches on patches.